Feb 13, 2011

Tag Toolbar 0.8.30b8

Tag Toolbar 0.8.30b8 is now available for download. It has been available since Jan 24 but the announcement delayed because my PC has broken after uploading it. Now I have new PC and am migrating data.

Changes in the beta are as follows:
  • Lightness:
    Transparency option in b7 is changed to Lightness. 0% means tag color and the more the value is increased, the lighter the color is.
  • Text color: 
    You can specify text color by one of the following 3 options:
    • Tag colors: Tag colors. Only when yellowish colors, text colors become black because it is hard to read them. And if you specify Lightness less than 50%, text colors are determined by Black/White option described below because it is hard to read them, too.
    • Black/White: Black or white. It is determined by brightness of background colors.
    • Complementary colors: Complementary colors of tag color.
  • Preview:
    Preview shows all available colors now.


Anonymous said...

Many thanks for your revision. Changing the Lightness works but changing Text Color does not have any effect in my Thunderbird Portable 3.1.7. Text color stays white no matter whether I choose Tag colors, Black/White, or Complementary colors (I restarted Thunderbird after each change). I tried different combinations of Lightness and Text color but text color stayed always white.
Any hint how to fix this?

h.ogi said...

Do you use a theme?

Anonymous said...

I have no theme installed. I used http://userstyles.org/styles/2437, which you mentioned in an earlier post. But I removed it from the profile (deleted the userChrome.css that contains the code) before I tested Tag Toolbar.

I have the impression that there is a bug in Thunderbird (TB) or Tag Toolbar (TT). It seems that TT has no or limited influence on tags that were present in TB before TT is installed. This would explain the behavior I have mentioned in my comments on "Beta test for Tag Toolbar 0.8.30 has started" and the behavior I observe now. Because with v0.8.30b3 tagging worked again after I deleted all pre-existing tags (Tools > Options > Display > Tags) and added my tags from scratch. Perhaps deleting the pre-existing tags would help this time as well (but I did not test it – I reverted back to http://userstyles.org/styles/2437).

h.ogi said...

Are you still using Mail tweaks? It extending thread pane coloring. It may conflict with Tag Toolbar.

Anonymous said...

I don't use Mail tweaks anymore.

h.ogi said...

Tag Toolbar does nothing about the coloring if the new coloring option is disabled. So, the problem happens in your environment is very strange.

I doubt tags created by mail tweaks cannot be handled by Thunderbird correctly.

Popular Posts